プロフィール
 

morimori.ynct

Author:morimori.ynct
森下功啓製作所のブログです。
電子工作のことや日々思ったことを時々気まぐれに更新しています。
趣味で作っているサイトはこちら

 
最新記事
最新コメント
最新トラックバック
 
 
月別アーカイブ
カテゴリ
 
 

スポンサーサイト

 
--/--/--(--) Category : スポンサー広告
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
 
Comment  |  Trackback
 
 

Anacondaでmatplotlibを使うとpyparsingが古いためにエラーが出る

 
2014/02/02(Sun) Category : プログラミング
Anacondaでmatplotlibを使おうとをするとpyparsingが古いためにエラーが出ました。

症状が出た環境は以下の通り。
Anaconda:1.8.0
env:python 3.3(Python 3.3環境を作ってメインで使っている)
マシン:Windows 7 x86/64

エラーメッセージを読むと、matplotlibが利用するpyparsingというパッケージがpy27用だ!とのことでした。そこで、pipを使って最新版をインストールしました。しかし標準では古い方を取ってきてしまうのでバージョンを指定しました。

$ pip install pyparsing==2.0.1

ここで、pyparsingの最新版は以下のページを参照するとわかります。
http://sourceforge.net/projects/pyparsing/files/pyparsing/


最初はPython用エディタpyscripterを起動させている影響か、pyparsingとはまた別のパッケージの読み込みエラーが多発していたのですが、結局はpyparsingパッケージのみのインストールで症状は治まりました。


[2014-03-20 追記]
 現在、Anacondaの1.9.xがリリースされています。上記のバグは修正されたようです。
関連記事
スポンサーサイト
 
コメントアイコン Comment0  |  Trackback0
 
 

Trackback

 

Trackback URL :
この記事にトラックバックする(FC2ブログユーザー)

 
 

Comment

 

    
 
Home | Top ▲
 
検索フォーム
 
 
RSSリンクの表示
リンク
ブロとも申請フォーム
QRコード
 
QR
 
 
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。